PlViewer Users Guide

Introduction

PlViewer is a Java application designed for analyzing log files generated by Digital Tuning Inc.’s PocketLOGGER( product – an automotive datalogger for Palm Computing platforms.

Starting PlViewer

Once installed, PlViewer may be started by double clicking on the PlViewer.jar file or the link, if you chose to create one during installation (PC Windows user), or by typing;

java –jar <PlViewer directory>/PlViewer.jar

where <PlViewer directory> is the directory in which PlViewer is installed (Linux users). If Java is installed correctly, PlViewer will display the main application window.
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Figure 1 - The main window

The application menu bar contains five drop down menus
. The File menu contains options for loading and saving log files, setting print options, and printing graphs. The Preferences menu contains parameter and graph configuration options. These enable you to set up parameter colors, scaling values, etc. The Windows menu provides extra display options for viewing the log data. The Tools menu is where most modules add utility commands, for example, the direct PDA download via serial link. The Help menu provides information about the current version of PlViewer.

Loading a log

Loading log files is done via the File->Open… menu option. This will bring up a standard file ‘Open’ dialog, from which you may navigate the directory hierarchy and select the log file you wish to load.
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Figure 2 - The File Open dialog

The file types drop down list displays a list of the file types that PlViewer currently supports
. The standard modules provided with PlViewer support PocketLOGGER( format databases, and CSV format logs.

A log file can be selected for loading by double clicking on it’s entry in the file list, or by selecting it with a single click, and the selecting the ‘Open’ option. Selecting ‘Cancel’ will return you to the main PlViewer window without loading a log.

After selecting a log for loading, PlViewer will return to the main application window to display the graphs.
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Figure 3 - The graph display

By left clicking on a graph, PlViewer will display a vertical line through all the graphs at the nearest sample time. The legends will indicate the sample values for the displayed parameters and the time value below the menu bar will display the actual time stamp of the samples.

The slider bar at the bottom of the window can be used to rapidly scroll forwards and backwards through the sample data.

A region of a graph can be selected by pressing and holding the Shift key while clicking the left mouse button. The toolbar will indicate the size of the selected region in seconds.
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Figure 4 - Selecting a region

Configuring the Graph Display

Adding and removing parameters 

PlViewer can display multiple graphs, and you can display as many parameters on each graph as you wish. Changing the parameters displayed is done by using a graph’s pop-up menu. Right click on a graph to obtain the pop-up menu, and then select the ‘parameters’ sub menu.
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Figure 5 - Graph pop-up menu

The parameters submenu lists all the parameters in the current log with checkboxes. The checkboxes for those parameters already displayed in the graph will be checked. Parameters can be added or removed by toggling a parameters checkbox. Each time a parameter is selected, the submenu will be closed and the graph updated.

Adding and removing graphs

New graphs can be created by using the graph button on the toolbar below the main menu.
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This will create an empty graph below your existing graphs. If the current application window is not large enough to display the extra graph, a vertical scrollbar will appear on the right side of the application window. This allows you to scroll down and view the new graph.

To close a graph, use the ‘Close’ option on the graphs pop-up menu.

Graph Setup

You can configure other properties of the graph, such as scaling values, height and colors via the ‘Graph Setup’ option on the ‘Preferences’ menu. This will open a dialog box which contains a number of options.
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Figure 7 - Graph Setup options

The Options group provides checkboxes for toggling three options;

· The ‘Legends enabled’ checkbox allows you to enable or disable to display of the parameter legends, which are displayed above each graph. This legend shows the color of each parameter being displayed on the graph and the sample value at the currently selected time sample.

· The ‘Seconds marks enabled’ checkbox allows you to switch off the tick marks displayed at one second intervals along a graphs horizontal axis.

· The ‘Sample cursor enabled’ checkbox can be used to enable or disable the drawing of the time cursor – the vertical line displayed on the graphs when you left click with the mouse.

The Scaling group provides two configurable values;

· The ‘Time/pixel ratio’ value define how many screen pixels correspond to one second on a graphs horizontal axis. You can enter a value here directly, or use the ‘Zoom In’ and ‘Zoom Out’ options on a graphs pop-up menu.

· The ‘Graph height’ value defines the height of the graphs vertical axis in screen pixels.

The Colors group provides four color configuration options. By clicking on the colored rectangular button, a color chooser dialog is displayed. This allows you to configure the colors from a selection grid, as HSB or RGB values.

· The ‘Graph background’ color is used to paint the graph background.

· The ‘Graph axes’ color is used to draw the horizontal and vertical axes on the graphs.

· The ‘Graph selection’ color is used to draw the currently selected region of a graph (to select a region, click-shift-drag with the left mouse button).

· The ‘Legend text’ color is used to display the parameter sample values in the graph legends (if enabled).

Once you have configured the values, the ‘OK’ button will accept the new changes and close the Graph Setup window. The ‘Apply’ button will accept the new values, but leave the dialog displayed. The Cancel button will discard the changes and close the dialog.

Parameter Setup

Parameter configuration options, such as color and scaling values, can be accessed via the ‘Parameters’ option on the ‘Preferences’ menu. This opens up the Parameter Configuration dialog box.
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Figure 8 - Parameter Setup options

This dialog displays a scrollable list of all the configured parameters
 in alphabetic order.  There are four columns;

· The first column gives the parameter name as it is displayed in the graph legends. 

· The second column displays the parameter minimum value. This is the value of a parameter at the bottom of a graph’s vertical axis. If no value is provided, PlViewer will use the minimum value from the current log.

· The third column displays the parameter maximum value. This is the value of a parameter at the top of a graph’s vertical axis. If no value is provided, PlViewer will use the maximum value from the current log.

· The fourth column is the color used to draw the parameters sample values in a graph. By clicking on the colored rectangular button, a color chooser dialog is displayed. This allows you to configure the colors from a selection grid, as HSB or RGB values.

Once you have configured the values, the ‘OK’ button will accept the new changes and close the Parameter Configuration window. The ‘Apply’ button will accept the new values, and leave the dialog displayed. The Cancel button will discard the changes and close the dialog.

By clicking on a parameter name in the first column, an ‘Edit Parameter’ dialog is displayed.
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Figure 9 - Edit Parameter dialog

This gives you three further configuration options;

· The ‘Parameter Name’ is the display name of the parameter. This is used in PlViewer, for example, in the legends, and in a graphs pop-up ‘Parameters’  submenu.

· The ‘Parameter Description’ is simply a brief description of the parameter.

· The ‘Aliases’ is a list of other names (aliases) that represent this parameter. These are used by the input filters to map parameter names (for example, in a CSV log file) into the PlViewer parameters
.

Other Display Options

Legend Window

The legend window can be displayed by selecting the ‘Legend’ option on the ‘Windows’ menu.
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Figure 10 - The graph Legend

This displays the values of all the parameters in the log file at the currently selected time sample. Left clicking on a graph to select a new time sample will cause the legend to be updated with the sample values at the selected time.

Data Window

The data window can be displayed by selecting the ‘Data’ option on the ‘Windows’ menu.
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Figure 11 - The Data window displays the raw sample values

This displays the raw sample data in table (spreadsheet) form. Individual or multiple rows of data may be selected my clicking and dragging the cursor in the data window. The PlViewer cursor will be updated, and any selection will be highlighted in the graphs to match the selections made in the data window.  

Printing Graphs

PlViewer provides options to configure and print graphs on your printer. Three print options are available from the File menu, Page Setup, Print Preview and Print. 

Page Setup

Selecting ‘Page Setup’ from the ‘File’ menu will display the ‘Page Setup’ dialog.
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Figure 12 - The Windows 'Page Setup' dialog

This provides configuration options to set the paper size, margins, orientation, etc
.

Print Preview

The ‘Print Preview’ option on the ‘File’ menu gives you the opportunity to see what your printed graphs will look like before you print them.

[image: image12.png]cose | [o_|~]





Figure 13 - Previewing graphs before printing

Depending upon the number of graphs displayed and the print options, this may be split into multiple pages. A toolbar contains a drop down list of scaling factors, allowing you to preview the graphs different sizes. You may also enter a custom size directly, by double clicking on the current value and entering a new value. Once you have finished with the ‘Print Preview’ dialog, select the ‘Close’ button.

Print

Selecting ‘Print’ from the ‘File’ menu will display the ‘Print’ dialog box. Depending upon the platform, this will provide further options to configure the printer and the number of copies. To print the graphs, select the ‘OK’ button.

The Scattergraph

The Scattergraph utility can be accessed by selecting the ‘Scatter’ option on the ‘Tools’ menu. This will display the Scattergraph dialog, which allows you to plot two parameters against each other. 
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Figure 14 - The Scattergraph tool

If a region of  a graph has been selected, the Scattergraph will plot only the parameter samples in the selected time period, otherwise it will plot the parameter samples for the entire log.

Two drop down lists are provided on the toolbar. These allow you to select the parameters to plot on the X and Y axes. Only the parameters in the current log will be displayed.

To determine the parameter values at any point in the graph, simply click on the graph at the desired point. The Scattergraph will display the parameter values at that point on the toolbar. To close the Scattergraph, click on the ‘Close’ button on the toolbar.

Saving GIF images

It is possible to save the current graph(s) as a GIF image by selecting the ‘Save GIF’ option from the ‘File’ menu;
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You will be presented with a ‘Save graph as GIF image’ dialog, which allows you to enter the name and location of the GIF image to be created. PlViewer will not automatically append a ‘.gif’ suffix to the filename, so if this is required, you must add it yourself.
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� Extension modules may add further drop-down menus


� This list may vary, depending upon the modules installed.


� Some parameters will be specific to each of the DSM/OBDII versions of PocketLOGGER(.


� Change these values with caution – it may affect PlViewer’s ability to load log files.


� Page Setup options will vary between platforms.





